HttpComponents Client 5.0.2 GA 发布

栏目: 软件资讯 · 发布时间: 6年前

内容简介:HttpComponents Client 5.0.2 GA 已发布,此版本将 HttpCore 升级至最新版本,提升了 RFC 7235 的一致性,并解决了自 5.0.1 版本以来发现的部分问题。 HTTPCLIENT-2116: 通过代理路由进行请求时,请求消息的构成不...

HttpComponents Client 5.0.2 GA 已发布,此版本将 HttpCore 升级至最新版本,提升了 RFC 7235 的一致性,并解决了自 5.0.1 版本以来发现的部分问题。

  • HTTPCLIENT-2116: 通过代理路由进行请求时,请求消息的构成不正确
  • PoolingAsyncClientConnectionManager 错误地将 Ping 命令发送到 HTTP/1.1 端点
  • HTTPCLIENT-2115: HttpAsyncClientBuilder 和 H2AsyncClientBuilder 没有将`replaceExecInterceptor()`考虑在内
  • 避免在 304 响应中更新 Content-Length header
  • HTTPCLIENT-2105: 异步客户端错误地处理了带有封闭实体的请求重定向
  • HTTPCLIENT-2100: MultipartEntityBuilder 对 EXTENDED 模式的处理不正确
  • HTTPCLIENT-2099, HTTPCLIENT-2091: 修复 SSLConnectionSocketFactory 连接超时的问题
  • ……

详情查看发布说明。

5.0 系列中包含的显著更改和特性包括:

  • 支持 HTTP/2 协议,并符合最新的 HTTP/2 协议规范文档的要求和建议(RFC 7540,RFC 7541)
  • 更好地符合最新的 HTTP/1.1 协议规范文档的要求和建议
  • 由于没有全局池锁,因此具有宽松的连接限制的新连接池实现保证了更高的并发性能和更好的性能
  • 支持 Reactive Streams API
  • 程序包命名空间已更改为 “org.apache.hc.client5”

下载地址:http://hc.apache.org/downloads.cgi


以上所述就是小编给大家介绍的《HttpComponents Client 5.0.2 GA 发布》,希望对大家有所帮助,如果大家有任何疑问请给我留言,小编会及时回复大家的。在此也非常感谢大家对 码农网 的支持!

查看所有标签

本站部分资源来源于网络,本站转载出于传递更多信息之目的,版权归原作者或者来源机构所有,如转载稿涉及版权问题,请联系我们。

深入浅出强化学习:原理入门

深入浅出强化学习:原理入门

郭宪、方勇纯 / 电子工业出版社 / 2018-1 / 79

《深入浅出强化学习:原理入门》用通俗易懂的语言深入浅出地介绍了强化学习的基本原理,覆盖了传统的强化学习基本方法和当前炙手可热的深度强化学习方法。开篇从最基本的马尔科夫决策过程入手,将强化学习问题纳入到严谨的数学框架中,接着阐述了解决此类问题最基本的方法——动态规划方法,并从中总结出解决强化学习问题的基本思路:交互迭代策略评估和策略改善。基于这个思路,分别介绍了基于值函数的强化学习方法和基于直接策略......一起来看看 《深入浅出强化学习:原理入门》 这本书的介绍吧!

CSS 压缩/解压工具
CSS 压缩/解压工具

在线压缩/解压 CSS 代码

Markdown 在线编辑器
Markdown 在线编辑器

Markdown 在线编辑器

正则表达式在线测试
正则表达式在线测试

正则表达式在线测试