IT资讯 Rails 框架默认 JavaScript 打包器 “Webpacker” 正式退役

enrique · 2022-01-21 09:30:06 · 热度: 5

Rails 是一个 Web 应用程序框架,是 Ruby 最早也是最出名的一个框架,可以说是 MVC (模型-视图-控制器)开发的先驱者。

在 7.0 之前的版本, Rails 一直使用 Webpacker 作为其默认 JavaScript 打包器。但随着 Rails 7.0 版本esbuild、rollup.js 和 Webpack  三大 JavaScript 捆绑器的集成,Webpacker 变得无关紧要(关于该 jsbundling-rails 新 JS 集成包的详细分析可点此查看)。

终于在 2022 年 1 月19 日,Webpacker 开发组正式宣布该项目已退役。

Rails 框架默认 JavaScript 打包器 “Webpacker” 正式退役

Webpacker 的版本号停留在 v6.0.0.rc.6 ,6.0 正式版本已停止开发或发布,未发布的 Webpacker v6 的代码被转移到在一个名为 Shakapacker 的新 gem 包下继续开发。但即便 v6 发布了,Rails 也不会将其作为官方的 gem 包(gem 是 Ruby 语言的包格式)发布。

由于老版本的 Rails 框架仍然依赖 Webpacker ,因此 Webpacker 5.x 系列仍然有人在维护。但官方建议火速迁移到其他 JavaScript 捆绑器,并提供了迁移指南 —— 特别推荐迁移到 Webpack 。

猜你喜欢:
暂无回复。
需要 登录 后方可回复, 如果你还没有账号请点击这里 注册