HttpComponents Core 5.0 alpha4 发布

栏目: 软件资讯 · 发布时间: 9年前

内容简介:HttpComponents Core 5.0 alpha4 已发布,这是一个主要版本,它的 HttpCore API 与稳定的 4.x 分支不兼容,并根据最新协议规范的要求和建议升级了 HTTP/1.1和 HTTP/2 协议。 5.0 系列中部分值得关注的变更和功能:...

HttpComponents Core 5.0 alpha4 已发布,这是一个主要版本,它的 HttpCore API 与稳定的 4.x 分支不兼容,并根据最新协议规范的要求和建议升级了 HTTP/1.1和 HTTP/2 协议。

5.0 系列中部分值得关注的变更和功能:

  • Support for HTTP/2 protocol and conformance to requirements and recommendations of the latest HTTP/2 protocol specification (RFC 7540,RFC 7541)

  • Improved conformance to requirements and recommendations of the latest HTTP/1.1 protocol specification (RFC 7230, RFC 7231)

  • New asynchronous HTTP transport APIs consistent for both HTTP/1.1 and HTTP/2 transport.

  • Redesigned I/O reactor APIs and improved NIO based reactor implementation for a greater performance and scalability.

详情请参阅发布主页和更新说明

请注意,从 5.0 开始,HttpCore 需要 Java 1.7 或更高版本。

下载地址

HttpComponents 也就是以前的 httpclient 项目,可以用来提供高效的、最新的、功能丰富的支持 HTTP 协议的客户端/服务器编程 工具 包,并且它支持 HTTP 协议最新的版本和建议。不过现在的 HttpComponents 包含多个子项目,有:

  • HttpComponents Core

  • HttpComponents Client

  • HttpComponents AsyncClient

  • Commons HttpClient


【声明】文章转载自:开源中国社区 [http://www.oschina.net]


以上就是本文的全部内容,希望对大家的学习有所帮助,也希望大家多多支持 码农网

查看所有标签

本站部分资源来源于网络,本站转载出于传递更多信息之目的,版权归原作者或者来源机构所有,如转载稿涉及版权问题,请联系我们。

乔纳森传

乔纳森传

利恩德·卡尼 / 汪琪 岳卉 王文雅 / 中信出版社 / 2014-1-1 / 49

抛开苹果公司,单就设计行业来讲,乔纳森也是一个特殊的人物。他推动了设计行业的大变革:不再为产品增加看起来炫得多的配件,而是要去掉多余的东西。 ——陈向东 终于有一本书能够如此地接地气:它不再关注那位神一样的乔布斯,而是关注那位站在神的背后,同样具有神一样光环的乔纳森。 ——孙陶然 乔纳森•艾夫把他自己对科学、人文、艺术,乃至整个世界的感知尽数渗透进苹果的设计和审美之中,他是......一起来看看 《乔纳森传》 这本书的介绍吧!

RGB转16进制工具
RGB转16进制工具

RGB HEX 互转工具

Markdown 在线编辑器
Markdown 在线编辑器

Markdown 在线编辑器

UNIX 时间戳转换
UNIX 时间戳转换

UNIX 时间戳转换