视频 SIP/IMS 客户端 IMSDroid

码农软件 · 软件分类 · 开源SIP项目 · 2020-02-20 18:44:26

软件介绍

======

IMSDroid 是 Android 上的一个高质量的视频 SIP/IMS 客户端。值得关注的特性:

  • SIP(RFC 3261, 3GPP TS 24.229 Rel-9)

  • TCP and UDP over IPv4 or IPv6

  • Signaling Compression, SigComp(RFC 3320, 3485, 4077, 4464, 4465, 4896, 5049, 5112 and 1951)


  • Enhanced Address Book (XCAP storage, authorizations, presence, ...)

  • Partial supports for GSMA Rich Communication Suite release 3

  • Partial supports for One Voice Profile V1.0.0 (GSMA VoLTE)

  • Partial supports for MMTel UNI (used by GSMA RCS and GSMA VoLTE)


  • IMS-AKA registration (both AKA-v1 and AKA-v2), Digest MD5, Basic

  • 3GPP Early IMS Security (3GPP TS 33.978)

  • Proxy-CSCF discovery using DNS NAPTR+SRV

  • Private extension headers for 3GPP

  • Service Route discovery

  • Subscription to reg event package (Honoring network initiated (re/de/un)-registration events)


  • 3GPP SMS Over IP (3GPP TS 23.038, 24.040, 24.011, 24.341 and 24.451)

  • Voice Call (G729AB1, AMR-NB, iLBC, GSM, PCMA, PCMU, Speex-NB)

  • Video Call (VP8, H264, MP4V-ES, Theora, H.263, H.263-1998, H.261)

  • DTMF (RFC 4733)

  • QoS negotiation using Preconditions (RFC 3312, 4032 and 5027)

  • SIP Session Timers (RFC 4028)

  • Provisional Response Acknowledgments (PRACK)

  • Communication Hold (3GPP TS 24.610)

  • Message Waiting Indication (3GPP TS 24.606)

  • Calling E.164 numbers by using ENUM protocol (RFC 3761)

  • NAT Traversal using STUN2 (RFC 5389) with possibilities to automatically discover the server by using DNS SRV (TURN already implemented and ICE is under tests)

  

本文地址:https://www.codercto.com/soft/d/26047.html

C专家编程

C专家编程

Peter Van Der Linden / 徐波 / 人民邮电出版社 / 2008-2 / 45.00元

《C专家编程》展示了最优秀的C程序员所使用的编码技巧,并专门开辟了一章对C++的基础知识进行了介绍。 书中C的历史、语言特性、声明、数组、指针、链接、运行时、内存以及如何进一步学习C++等问题进行了细致的讲解和深入的分析。全书撷取几十个实例进行讲解,对C程序员具有非常高的实用价值。 本书可以帮助有一定经验的C程序员成为C编程方面的专家,对于具备相当的C语言基础的程序员,本书可以帮助他们......一起来看看 《C专家编程》 这本书的介绍吧!

HTML 压缩/解压工具
HTML 压缩/解压工具

在线压缩/解压 HTML 代码

RGB转16进制工具
RGB转16进制工具

RGB HEX 互转工具

在线进制转换器
在线进制转换器

各进制数互转换器